Etherchannel modes – PAGP, LACP and ON

EtherChannel is a link aggregation technology used primarily on Cisco switches. EtherChannel enables bundling of multiple physical Ethernet links to create one logical Ethernet link which provides high throughout and resilient links. EtherChannel can be provisioned across Cisco Switches and Routers.Upto 8 active links can be bundled to form EtherChannel for Fast Ethernet, Gigabit Ethernet and 10-GigabitEthernet links.

We can create an EtherChannel on a standalone switch, on a single switch in the stack, or on multiple switches in the stack (known as cross-stack EtherChannel). EtherChannel configuration can be in one of below enlisted 3 modes

Lets understand each one of EtherChannel modes in detail. Below diagram will be referred to while forming and configuring EtherChannel in PAgP, LACP and ON modes –

PAgP (Port-Aggregation Protocol)

PAgP is Cisco proprietary Etherchannel technology. It uses the multicast address of 01-00-0C-CC-CC-CC for communication.

Switch/Router Ports can form an EtherChannel when they are in different PAgP modes as per below criteria –

  • A port in the desirable mode can form an EtherChannel with another port that is in the desirable or auto mode.
  • A port in the auto mode can form an EtherChannel with another port in the desirable mode.

The port in desirable mode is one which sends requests to the other side to see if it is also using PAgP. The port in auto mode defines using PAgP but does not send requests.

Below table to summarize PAgP negotiation –

EtherChannel Configuration between Switch1 and Switch2 using PAgP is shown below –

Switch1(config)#interface range Gi0/0-3

Switch1(config-if-range)#channel-group 1 mode desirable

Switch1(config-if-range)#interface port-channel 1

Switch1(config-if)#switchport mode trunk

Switch2(config)#interface range Gi0/0-3

Switch2(config-if-range)#channel-group 1 mode auto

Switch2(config-if-range)#interface port-channel 1

Switch2(config-if)#switchport mode trunk

Note – Switch1 is configured under desirable mode while Switch2 under Auto mode to negotiate and form EtherChannel

 

LACP (Link Aggregation Control Protocol)

LACP is an open standard protocol and published under the 802.3ad specification. It uses the multicast address of 01-80-c2-00-00-02.

Switch/Router Ports can form an EtherChannel when they are in different LACP modes as per below criteria –

  • A port in the  active  mode can form an EtherChannel with another port that is in the  active  or  passive  mode.
  • A port in the  passive  mode cannot form an EtherChannel with another port that is also in the  passive  mode because neither port starts LACP negotiation.

The port in active mode negotiates with the other side to form Etherchannel while interface in passive mode indicates using LACP, but responds to requests only and does not sending any request.

Below table to summarize LACP negotiation

EtherChannel Configuration between Switch1 and Switch2 using LACP is shown below –

Switch1(config)#interface range Gi0/0-3

Switch1(config-if-range)#channel-group 1 mode Active

Switch1(config-if-range)#interface port-channel 1

Switch1(config-if)#switchport mode trunk

Switch2(config)#interface range Gi0/0-3

Switch2(config-if-range)#channel-group 1 mode Passive

Switch2(config-if-range)#interface port-channel 1

Switch2(config-if)#switchport mode trunk

Note – Switch1 is configured under Active mode while Switch2 under Passive mode to negotiate and form EtherChannel

 

Manual “ON” EtherChannel Mode

When using a EtherChannel “ON” mode, EtherChannel will be created only when another interface group is in EtherChannel “on” mode. One major drawback of using manually configured “On” EtherChannel Mode is that any layer one device like media convertor  or modem between 2 Etherchannel devices will not be able to diagnose link failure and keep on sending the traffic while PAgp/LACP configured devices will detect the failure and respond to it.

EtherChannel Configuration between Switch1 and Switch2 using “ON” configuration mode is shown below –

Switch1(config)#interface range Gi0/0-3

Switch1(config-if-range)#channel-group 1 mode on

Switch1(config-if-range)#interface port-channel 1

Switch1(config-if)#switchport mode trunk

Switch2(config)#interface range Gi0/0-3

Switch2(config-if-range)#channel-group 1 mode on

Switch2(config-if-range)#interface port-channel 1

Switch2(config-if)#switchport mode trunk

Note – Both Switch1 and Switch2 are configured under ON mode to forcefully form EtherChannel without negotiation.

Please follow and like us:

Related Post

Comments

comments

Add a Comment