Why we require LDP-IGP SYNC in MPLS

One of the problem faced in MPLS networks with LDP and IGP is when both are not synchronized.When we say synchronize we mean that both LDP and IGP should agree on an outgoing interface for a particular prefix.If by any means the LDP neighbor ship goes down but IGP remains UP, IGP will continue to use the link to forward the traffic which might get black-holed in MPLS VPN networks.When LDP breaks the IGP will forward the packet as IPV4 rather than Labelled packet, hence in MPLS VPN networks if the packet becomes unlabeled on any P/Backbone router it will get dropped as customer routes aren’t visible on P routers.

Another problem due to synchronization is that IGP converges much faster than LDP and hence begins to forward the traffic which might get dropped.A solution to above problem is the use of MPLS LDP-IGP SYNC.

Command to enable LDP-IGP SYNC:

R1#router ospf 1

R1(Config-if)#mpls ldp sync

This feature ensures link isn’t used to forward unlabeled traffic when the LDP session is down.Once the LDP comes up the link is used to forward the traffic then.

Let us use the simple topology below to understand how LDP-IGP SYNC works:

When LDP session is down, OSPF on R1 announces the link metric as maximum 65535 until synchronization is achieved.

After LDP session is established & label bindings are exchanged, the IGP advertises the link with its normal metric.

[the_ad_placement id=”ad-17sept17″]

LAB Testing:

R1 Config:

interface Loopback0

ip address 1.1.1.1 255.255.255.255

ip ospf 1 area 0

!

interface FastEthernet0/0

ip address 9.9.12.1 255.255.255.0

ip ospf 1 area 0

mpls ip

mpls label protocol ldp

!

router ospf 1

mpls ldp sync

R2 Config:

interface Loopback0

ip address 2.2.2.2 255.255.255.255

ip ospf 1 area 0

!

interface FastEthernet0/0

ip address 9.9.12.2 255.255.255.0

ip ospf 1 area 0

mpls ip

mpls label protocol ldp

!

router ospf 1

mpls ldp sync

Testing:

Currently Fa0/0 have LDP neighbor ship up and OSPF is also up.

We have enabled LDP-IGP SYNC on both R1 and R2 but haven’t enabled Hold-down timer for now.

R1#sh mpls ldp neighbor

Peer LDP Ident: 2.2.2.2:0; Local LDP Ident 1.1.1.1:0

TCP connection: 2.2.2.2.24122 – 1.1.1.1.646

State: Oper; Msgs sent/rcvd: 6/6; Downstream

Up time: 00:00:22

LDP discovery sources:

FastEthernet0/0, Src IP addr: 9.9.12.2

Addresses bound to peer LDP Ident:

9.9.12.2       2.2.2.2

R1#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

2.2.2.2           1   FULL/DR         00:00:37   9.9.12.2       FastEthernet0/0

Now we will break the LDP neighbor ship between R1 and R2 by removing the LDP ID from OSPF and clearing mpls ldp neighbor

R1(config)#int lo0

R1(config-if)#no ip ospf 1 area 0

R1#clear mpls ldp neighbor 2.2.2.2

Now we see the sync is not achieved as below:

R1#sh mpls ldp igp sync

FastEthernet0/0:

LDP configured; LDP-IGP Synchronization enabled.

Sync status: sync not achieved; peer reachable.

Sync delay time: 0 seconds (0 seconds left)

IGP holddown time: infinite.

IGP enabled: 1

R2#sh mpls ldp discovery

Local LDP Identifier:

2.2.2.2:0

Discovery Sources:

Interfaces:

FastEthernet0/0 (ldp): xmit/recv

           LDP Id: 1.1.1.1:0; no route

Also we see below that OSPF advertises the link with maximum metric

R1#sh ip ospf mpls ldp interface fa0/0

FastEthernet0/0

Process ID 1, Area 0

LDP is not configured through LDP autoconfig

LDP-IGP Synchronization : Required

Holddown timer is not configured

Interface is up and sending maximum metric

Now we will bring up the LDP Neighborship as below:

R1(config)#int lo0

R1(config-if)#ip ospf 1 area 0


R1#sh mpls ldp neighbor

Peer LDP Ident: 2.2.2.2:0; Local LDP Ident 1.1.1.1:0

TCP connection: 2.2.2.2.34178 – 1.1.1.1.646

State: Oper; Msgs sent/rcvd: 6/6; Downstream

Up time: 00:00:09

LDP discovery sources:

FastEthernet0/0, Src IP addr: 9.9.12.2

Addresses bound to peer LDP Ident:

9.9.12.2       2.2.2.2

R1#sh ip ospf mpls ldp interface fa0/0

FastEthernet0/0

Process ID 1, Area 0

LDP is not configured through LDP autoconfig

LDP-IGP Synchronization : Required

Holddown timer is not configured

Interface is up

R1#sh mpls ldp igp sync

FastEthernet0/0:

LDP configured; LDP-IGP Synchronization enabled.

       Sync status: sync achieved; peer reachable.

Sync delay time: 0 seconds (0 seconds left)

IGP holddown time: infinite.

Peer LDP Ident: 2.2.2.2:0

IGP enabled: 1

Please follow and like us:

Related Post

Comments

comments

Add a Comment