Configuring EIGRP STUB Feature

EIGRP Stub feature is mostly used with the hub and spoke topologies. Routers at the spoke sites are configured as stubs ensuring they the spoke sites don’t act as a transit path for the traffic.

A stub router will inform in EIGRP Hello packets that it has stub feature enabled and hence no queries are sent to stub router for any routes.

EIGRP stub is one way to tackle the well-known stuck-in-active issues in EIGRP networks.

Let us use the topology below to configure the EIGRP STUB feature on Router 2.

In the topology above we have formed EIGRP neighborship between Router 1 & 2 as below:

R1#sh ip eigrp neighbors

EIGRP-IPv4 Neighbors for AS(100)

H   Address             Interface             Hold  Uptime     SRTT   RTO   Q Cnt     Seq Num

(sec)                     (ms)

0   9.9.12.2               Fa0/0                 13        00:04:25  107      642      0            7 

 

We have used the following configuration on R2:

ip route 2.2.2.2 255.255.255.255 9.9.23.3

router eigrp 100

network 1.1.1.1 0.0.0.0

network 9.9.12.0 0.0.0.3

redistribute static metric 1000 1 255 1 1500

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 9.9.12.2 255.255.255.252

!

interface FastEthernet1/0

ip address 9.9.23.2 255.255.255.0

Now we will configure EIGRP Stub feature on R2 with following options and check the EIGRP routes on R1 accordingly.

  1. Eigrp stub Connected
  2. Eigrp stub static
  3. Eigrp stub receive-only
  4. Eigrp stub redistributed
[the_ad_placement id=”ad-17sept17″]

1: Configuring Eigrp stub Connected

R2(config-router)#eigrp stub connected

Verification:

Only connected subnet 1.1.1.1 is advertised to R1.Though 9.9.23.0/24 is also connected network but is not advertised as it isn’t advertised under EIGRP process.

R1#sh ip route eigrp

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets

D       1.1.1.1 [90/156160] via 9.9.12.2, 00:00:06, FastEthernet0/0

 

2: Configuring Eigrp stub static

R2(config-router)#eigrp stub static

Verification:

Only the static route to 2.2.2.2 is seen as advertised to R1.

R1#sh ip route eigrp

2.0.0.0/32 is subnetted, 1 subnets

D EX     2.2.2.2 [170/2562816] via 9.9.12.2, 00:00:07, FastEthernet0/0

 

3: Eigrp stub receive-only

R2(config-router)#eigrp stub receive-only

Verification:

No route is advertised to R1.

R1#sh ip route eigrp

Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2

i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2

ia – IS-IS inter area, * – candidate default, U – per-user static route

o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP

+ – replicated route, % – next hop override

Gateway of last resort is not set

 

4: Eigrp stub redistributed

R2(config-router)#eigrp stub redistributed

Verification:

Only the redistribute static route is seen to be advertised.

R1#sh ip route eigrp

2.0.0.0/32 is subnetted, 1 subnets

D EX     2.2.2.2 [170/2562816] via 9.9.12.2, 00:01:07, FastEthernet0/0

[the_ad_placement id=”ad-17sept17″]
Please follow and like us:

Comments

comments

Add a Comment